Система «ИТАН: Управленческий баланс» версия 2.4.150218.150512

12 мая 2015

Новое в версии:

Реализованы команды для показа проводок в документе с управляемыми формами документа и списка документов,
у которых есть не отключенная командная панель формы с не отключенным авто формированием.

Для открытия возможности просмотра проводок документа, заданного вида, необходимо включить его в список

Старые вызовы остались в силе, но тогда остается не доступным новая доработка:
-  Формирование сообщения в журнале сообщений при возникновении ошибки процедуры визирования.

Новые вызовы аналогичны старым но используются общие модули
«УБИ_ОО_Клиент» и  «УБИ_ОО_Сервер» вместо «УБИ_РД_Клиент» и  «УБИ_РД_Сервер».

Вот текст новых редакций вызовов для управляемой формы:

//УБИ: Процедуры Формы объекта. Обработка событий ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

&НаКлиенте

Процедура УБИ_РД_ФормаОбъекта_ЛокальнаяОбработкаСобытий(Элемент) Экспорт

      УБИ_ОО_Клиент.РД_ФормаОбъекта_ОбработкаСобытий(ЭтаФорма,Элемент,"Объект"); 

КонецПроцедуры

//УБИ: Процедуры Формы объекта. Обработка событий ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

&НаКлиенте

Процедура ПослеЗаписи(ПараметрыЗаписи)

      //УБИ: Процедуры Формы объекта. После записи ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      УБИ_ОО_Клиент.РД_ФормаОбъекта_ПослеЗаписи(ЭтаФорма,"Объект");

      //УБИ: Процедуры Формы объекта. После записи ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      …

КонецПроцедуры

&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

      //УБИ: Процедуры Формы объекта. При создании на сервере ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      УБИ_ОО_Сервер.РД_ФормаОбъекта_ПриСозданииНаСервере(ЭтаФорма,Отказ,"Объект");

      //УБИ: Процедуры Формы объекта. При создании на сервере ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      …

КонецПроцедуры

&НаСервере

Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

      //УБИ: Процедуры Формы объекта. После записи на сервере ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      УБИ_ОО_Сервер.РД_ФормаОбъекта_ПослеЗаписиНаСервере(ЭтаФорма,ТекущийОбъект);

      //УБИ: Процедуры Формы объекта. После записи на сервере ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      …

КонецПроцедуры

Наши клиенты